Мельница данных- Взаимодействие с разработчиком в случае ошибок, проблем, вопросов по работе системы  (раздел целиком)  (31.03.2020)
Взаимодействие с разработчиком в случае ошибок, проблем, вопросов по работе системы

В ситуациях, когда в работе системы происходят ошибки, когда система ведет себя неожиданным для пользователя образом, наблюдаются проблемы с быстродействием или другими аспектами работы системы, если у пользователей возникают вопросы, не освещенные в Руководстве пользователя, возникает необходимость обратиться к разработчику. Для того, чтобы разработчик мог решить проблему или ответить на вопрос быстро, полно и компетентно, ему нужно предоставить информацию о среде работе системы, о решаемых пользователем задачах, последовательности действий пользователя, приведших к проблемной ситуации.

Общими принципами сбора информации для обращения к разработчику должны быть:

  1. Необходимо быть готовым изложить последовательность действий пользователя в системе, начиная с открытия системы до ситуации, приводящей к ошибке, проблемной ситуации или ситуации, вызывающей вопрос.
  2. Если ошибка или проблема имеет визуальное проявление, нужно сделать скриншот (снимок) экрана. Желательно предоставлять скриншот всего экрана компьютера, а не только активного окна приложения, это даст разработчику дополнительную полезную информацию. Скришот экрана при работе в операционной системе MS Windows можно получить путем одновременного нажатия клавиш Ctrl + Print Screen (PrtScr) и последующей вставки (сочетание клавиш Shift + Ins) в какое-либо графическое приложение, например, программу Paint.
  3. Если ошибка заключается не в отображении специального окна с сообщением об ошибке, а в том, что результат работы системы является, с точки зрения пользователя, некорректным, то нужно быть готовым изложить, каким должен быть корректный результат, и чем именно результат работы системы некорректен.
  4. Если ошибка, проблема или вопрос связаны с работой третьесторонних приложений (например, отчеты, формируемые в MS Excel или MS Word, работа web-приложений системы посредством интернет-браузеров), нужно быть готовым предоставить информацию о версии третьесторонних приложений.
  5. Нужно быть готовым предоставить информацию о конфигурации рабочего места пользователя, версии операционной системы, установленном программном обеспечении и его версии, включая средства анитивирусной защиты.

Для сбора информации, необходимой разработчику для решения проблем, система предоставляет ряд средств: Приложение Отладочный монитор, возможность получения файла, содержащего информацию об ошибке, также ниже приведены рекомендации по получению информации о третесторонних приложениях.


1. Приложение Отладочный монитор

Приложение Отладочный монитор (DebugView.exe) устанавливается при установке платформы в любой конфигурации, предусмотренной по умолчанию, включая конфигурацию "Рабочее место пользователя". Открыть приложение можно при помощи иконки:

Иконка Debug Monitor

Когда приложение Отладочный монитор запущено, приложение Обозреватель данных выводит в него поток сообщений о действиях и событиях, происходящих в системе. В Отладочный монитор попадают все sql-запросы, направляемые с рабочего места пользователя на сервер баз данных (в случае удаленного подключения - html-запросы, направляемые на сервер приложений), информационные сообщения, предупреждения, отладочная информация, сообщения об ошибках и прочие данные.

DebugView screenshot

Для того, чтобы собрать и передать разработчику информацию об ошибке или проблемной ситуации при помощи Отладочного монитора, нужно выполнить следующие действия:

  1. Закрыть приложение Обозреватель данных, если оно было открыто.
  2. Запустить приложение Отладочный монитор. Если это приложение уже было открыто, то выполнить очитку всех имеющихся в нем сообщений при помощи кнопки Очистить.
  3. В приложение Обозреватель данных выполнить всю последовательность действий, приводящих в появлению ошибки или проблемной ситуации.
  4. После возникновения ошибки или проблемной ситуации в приложении Отладочный монитор нажать кнопку Сохранить в файл, выбрать место сохранения и задать имя файла. Файл будет сохранен в формате.txt.
  5. Отправить полученный.txt-файл разработчику в составе других информационных материалов, которыми должны быть:
    • Словесное описание проблемы и способа ее воспроизведения
    • Один или несколько скриншотов экрана, иллюстрирующих проблему

После получения информации, состав которой описан в пункте 5, разработчик может запросить дополнительную информацию о проблеме.


2. Получение файла, содержащего информацию об ошибке

В ходе работы с системой могут отображаться специальные окна с информацией об ошибках. Эти окна могут быть двух видов:

  1. Окно с информацией о недопустимом действии пользователя (окно с шапкой синего цвета):

    Окно ошибки. Синяя шапка.

    Как правило, отображение такого окна с информацией об ошибке свидетельствует не об ошибке в функциональности системы, а о том, что пользователем выполнено недопустимое действие. Информация о том, в чем именно действие не допустимо, содержится в тексте, отображаемом в окне. Например, на приведенном выше скриншоте мы видим окно с ошибкой, отображено после попытки пользователя создать в справочнике "Уровни образования и курсы" второй записи с именем "1 курс", подчиненной родительской записи "Бакалавриат", что недопустимо. Поэтому сообщение об ошибке говорит о дублировании объекта по полю Имя.

    Информация, отображаемая в окне данного вида, предназначена для пользователя. Вы можете направить информацию о такой ошибке разработчику в случае, если сообщение об ошибке непонятно, либо если считаете, что выполненное пользователем действие должно быть допустимым, и ошибка системы в том, что действие было расценено как недопустимое.

    При отображении окна данного вида пользователь может продолжить работу, нажав на кнопку Продолжить. При необходимости обратиться в данной ситуации к разработчику до нажатия кнопки Продолжить необходимо получить и сохранить информацию, необходимую разработчику для анализа ситуации, при помощи ссылок "Показать информацию для службы поддержки" или "Сформировать файл для службы поддержки". Подробнее о сохранении этой информации написано ниже.

  2. Окно с информацией об ошибке системы (окно с шапкой красного цвета).

    Окно ошибки. Красная шапка.

    При возникновении ситуации, сопровождающейся появлением такого окна, необходимо получить и сохранить информацию, необходимую разработчику для анализа ситуации, при помощи ссылок "Показать информацию для службы поддержки" или "Сформировать файл для службы поддержки". Подробнее о сохранении этой информации написано ниже.

    После сохранения информации об ошибке можно попытаться продолжить работу, нажав кнопку Продолжить. В некоторых случаях, в зависимости от характера произошедшей ошибки, продолжение работы может оказаться невозможным, в таких случаях нужно нажать кнопку Закрыть приложение. После того, как приложение будет закрыто, его можно будет открыть снова и продолжить работу.

Сохранение информации для направления разработчику.

Информация, которая поможет разработчику решить проблему, не отображается в самом окне, поэтому направлять разработчику скриншот именно этого окна не имеет смысла. Для получения необходимой для разработчика информации в окнах с сообщением об ошибке обоих видов расположены ссылки "Показать информацию для службы поддержки" или "Сформировать файл для службы поддержки".

По ссылке Показать информацию для службы поддержки информация отображается в том же окне. Весь текст изначально выделен, его можно сразу скопировать и вставить в текстовый файл, в тело письма и т.д. Данный текст содержит сам текст ошибки, а также информацию об операционной системе пользователя и ее версии, загруженных модулях, переменных окружения и проч.

Информация для службы поддержки

При помощи ссылки Сформировать файл для службы поддержки можно собрать в удобном виде наиболее полную и полезную для разработчика информацию. После нажатия на ссылку будет предложен диалог сохранения файла. По умолчанию файлу будет дано имя ExceptionInfo.err. Это имя можно изменить, но расширение необходимо файла сохранить. После выбора места сохранения и имени файла и нажатия кнопки Сохранить, система отобразить предупреждение:

Предупреждение при сохранении файла для службы поддержки

К данному предупреждению нужно отнестись ответственно - отправлять полученный файл только на адреса службы поддержки системы в вашей организации или на официальный контактный адрес разработчика (если вы взаимодействуете с разработчиком напрямую). После отправки этот файл необходимо удалить.

Предоставление разработчику информации в виде.err-файла - это самый удобный и надежный вариант взаимодействия, который даст возможность разработчику решить проблему или ответить на вопрос наиболее эффективным и быстрым образом. Данный файл содержит все виды информации, которые могут быть собраны другими способами:

  • Информацию об ошибке, которая отображается по ссылке "Показать информацию для службы поддержки"
  • Сообщения Отладочного монитора, собранные за некоторое время до возникновения ошибки
  • Скриншоты экрана пользователя, включая скриншот окна с информацией об ошибке.

При отправке файла разработчику дополнительно нужно описать последовательность действий, приведших к ошибке или ситуации, вызывающей вопросы. После получения файла и дополнительной информации, разработчик может попросить предоставить дополнительную информацию о проблемной ситуации, о конфигурации рабочего места пользователя, прочем установленном на рабочем месте ПО и проч.

Если вы хотите обратиться к разработчику по поводу ситуации, которая не сопровождается отображением окна с ошибкой, то.err-файл можно получить следующим образом: нужно кликнуть левой кнопкой мыши по иконке с мельницей в левом углу заголовка окна текущей формы и из выпадающего меню выбрать пункт Сохранить файл для службы поддержки.

Получение файла для службы поддержки

3. Получение информации о третесторонних приложениях

В случае, если ошибка произошла при взаимодействии системы с третьесторонним приложением, например, при выполнении отчета MS Excel, MS Word, pdf, при работе web-приложений системы через интернет-браузер, разработчику, в дополнение к файлу с информацией об ошибке, понадобится информация о версии третьестороннего приложения, при взаимодействии с которым произошла ошибка.

Получить информацию о версии приложения можно, как правило, в окне О программе ("About box"), которое в большинстве программных продуктов представлено в пункте меню Справка.

Разработчику в составе информационных материалов нужно отправить скриншот этого окна.

В продуктах семейства Microsoft Office вызвать окно О программе можно разными способами в зависимости от версии MS Office. В программных продуктах версий до 2003 включительно это окно доступно в меню Справка / О программе. В программных продуктах версий 2007 и выше вызвать это окно можно следующим образом:

  1. В меню Файл открыть выпадающий список доступных действий и нажать кнопку Параметры Excel :
    Параметры Excel
  2. В открывшемся окне выбрать раздел Ресурсы, в правой части окна нажать кнопку О программе :
    Вызов окна О программе Excel

Окно О программе в случае MS Excel выглядит следующим образом:

Окно О программе Excel

В программе Acrobat Reader окно О программе можно вызвать из меню Справка / О программе :

Вызов окна О программе Acrobat Reader

В интернет-браузерах окно "О программе" (О Google Chrome, О FireFox, О Internet Explorer) также можно вызвать из меню Справка. Строка меню в интернет-браузерах часто бывает по умолчанию скрыта. Для того, чтобы ее отобразить, нужно нажать клавишу Alt на клавиатуре.